<div dir="ltr">Great!  You're welcome! :)</div><div class="gmail_extra"><br><br><div class="gmail_quote">On Sun, Oct 20, 2013 at 10:38 PM, Dark_Oppressor <span dir="ltr"><<a href="mailto:DarkOppressor@gmail.com" target="_blank">DarkOppressor@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><u></u>




        <div>

        <div>Oh my goodness Sam, you are the man! Thank you! My Linux and OSX builds are both working now.<br>
<br>
<div align="center"><br><br><table width="90%" align="center" cellspacing="1" cellpadding="2" border="0"><tbody><tr><td><br>
</td></tr><tr> 
        <td align="left">Sam Lantinga wrote:</td><td><br>
</td></tr><tr><td><br>
</td></tr><tr>
        <td align="left">Fixed, thanks!<a href="http://hg.libsdl.org/SDL/rev/af63b63e7aac" target="_blank">http://hg.libsdl.org/SDL/rev/af63b63e7aac</a><br>
<br>
<br>
<br>
<br>
On Sun, Oct 20, 2013 at 4:09 PM, Dark_Oppressor <> wrote:<br>
<div align="center"><br><br><table width="90%" cellspacing="1" cellpadding="2" border="0" align="center"><tbody><tr><td><br>
</td></tr><tr> 
        <td align="left">Quote:</td><td><br>
</td></tr><tr><td><br>
</td></tr><tr>
        <td align="left"><div><div class="h5"><span style="text-decoration:underline"></span>               I'm using SDL2 and I've just been adding some SDL2_gfx functionality to my program. In Windows, I'm using the pre-built 2.0.0 SDL2, and I've compiled R5 of SDL2_gfx. That works fine.<br>

<br>
So I've started adding it to Linux. I built SDL2 from source using the 2.0.0 stable source release. I built R5 of SDL2_gfx. However, my program compiles but then fails to link, saying there are multiple definitions of several functions. These are:<br>

<br>
_transformSurfaceRGBA<br>
_rotozoomSurfaceSizeTrig<br>
_colorkey<br>
transformSurfaceY<br>
<br>
The only use of SDL2_gfx in my program is:<br>
1) #include <span style="text-decoration:underline"></span><br>
2) filledCircleRGBA<br>
3) circleRGBA<br>
4) thickLineRGBA<br>
<br>
If I comment out those 3 function calls it links fine, of course.<br>
<br>
As far as I can tell, everything is identical between the two setups (same linking order and everything), so what on earth is causing the Linux version to freak out? How can this problem only occur in Linux and not Windows? How can I fix it?<br>

        <br>
<br></div></div>
_______________________________________________<br>
SDL mailing list<br>
<br>
<a href="http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org" target="_blank">http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org</a><br>
<br>
</td><td><br>
        </td></tr><tr><td><br>
</td></tr></tbody></table></div></td><td><br>
        </td></tr><tr><td><br>
</td></tr></tbody></table></div></div>
        </div>

<br>_______________________________________________<br>
SDL mailing list<br>
<a href="mailto:SDL@lists.libsdl.org">SDL@lists.libsdl.org</a><br>
<a href="http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org" target="_blank">http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org</a><br>
<br></blockquote></div><br></div>