<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<style type="text/css">
<!--

/*
  The original subSilver Theme for phpBB version 2+
  Created by subBlue design
  http://www.subBlue.com

  NOTE: These CSS definitions are stored within the main page body so that you can use the phpBB2
  theme administration centre. When you have finalised your style you could cut the final CSS code
  and place it in an external file, deleting this section to save bandwidth.
*/


 /* General page style. The scroll bar colours only visible in IE5.5+ */
body {
        background-color: #;
        font-family: ;
        font-size: 11;
        color: #;
}

/* General font families for common tags */
font,th,td,p { font-family:  }
p, td           { font-size : 11; color : #; }
a:link,a:active,a:visited { color : #; }
a:hover         { text-decoration: underline; color : #; }
hr      { height: 0px; border: solid # 0px; border-top-width: 1px;}
h1,h2           { font-family: "Trebuchet MS", Verdana, Arial, Helvetica, sans-serif; font-size : 22px; font-weight : bold; text-decoration : none; line-height : 120%; color : #000000;}


/* This is the border line & background colour round the entire page */
.bodyline       { background-color: #; border: 1px # solid; }


/* General text */
.gen { font-size : 12px; }
.genmed { font-size : 11px; }
.gensmall { font-size : 10px; line-height: 12px}
.gen,.genmed,.gensmall { color : #; }
a.gen,a.genmed,a.gensmall { color: #; text-decoration: none; }
a.gen:hover,a.genmed:hover,a.gensmall:hover     { color: #; text-decoration: underline; }


/* Forum title: Text and link to the forums used in: index.php */
.forumlink              { font-weight: bold; font-size: 12px; color : #; }
a.forumlink     { text-decoration: none; color : #; }
a.forumlink:hover{ text-decoration: underline; color : #; }


/* The content of the posts (body of text) */
.postbody { font-size : 12px; line-height: 18px}
a.postlink:link { text-decoration: none; color : # }
a.postlink:visited { text-decoration: none; color : #; }
a.postlink:hover { text-decoration: underline; color : #}


/* Quote & Code blocks */
.code {
        font-family: ; font-size: 11px; color: #3FB753;
        background-color: #; border: #; border-style: solid;
        border-left-width: 1px; border-top-width: 1px; border-right-width: 1px; border-bottom-width: 1px
}

.quote {
        font-family: ; font-size: 11px; color: #444444; line-height: 125%;
        background-color: #; border: #; border-style: solid;
        border-left-width: 1px; border-top-width: 1px; border-right-width: 1px; border-bottom-width: 1px
}

-->
</style>
</head>
        <body>

        <div class="postbody">It is some weeks old, I will update and check if it works as soon as I have time.<br />
Not now, because I can't risk break anything in my personal project in the next weeks, it is approaching my deadline =]<br />
<br />
<div align="center"><table width="90%" align="center" cellspacing="1" cellpadding="2" border="0" class="quote"><br /> <tr> <br />         <td class="quote_user" align="left">Sam Lantinga wrote:</td><br /> </tr><br /> <tr><br />         <td class="quote" align="left">That's weird.  Are you using the latest official project?<br />
<br />
<br />
<br />
On Wed, Feb 8, 2012 at 7:48 PM, RodrigoCard <> wrote:<br />
<div align="center"><table width="90%" cellspacing="1" cellpadding="2" border="0" align="center" class="quote"><br /> <tr> <br />         <td class="quote_user" align="left">Quote:</td><br /> </tr><br /> <tr><br />         <td class="quote" align="left"><span style="text-decoration: underline"></span>                 In fact, this problem was happening just with the static library, the framework version worked just fine.<br />
And Yes, it was not linking to the .o file.<br />
The fix was pretty simple, I just included the "SDL_dropevents.c" in the static library target, it was not there, ha! Silly like this. =D<br />
<br />
But I still cant drop anything to my app, I need to change something in the app's plist?<br />
<br />
<br />
<br />
<br />
<br />
        Sam Lantinga wrote:<br />
<br />
        That's very strange.  If you look at the static library build step, it builds SDL_dropevents.c, and it's not very complicated, it's just one function - the one that it can't find for some reason...<br />
<br />
Can you look at the link line and make sure it's linking that .o file?<br />
<br />
<br />
On Mon, Feb 6, 2012 at 11:24 AM, RodrigoCard <> wrote:<br />
<br />
<br />
<br />
        Quote:<br />
<br />
                        The library itself is builds just fine, but I got a error when linking SDL static library in my application.<br />
I included every framework included by SDL, and it works without senddropfile, so I dont know what more to do for now.<br />
<br />
I am using Xcode 4.1 on OSX Lion 10.7.2, and using a revision from a bit before the SDL2 rename.<br />
<br />
Here is the error:<br />
<br />
"Undefined symbols for architecture i386:<br />
_SDL_SendDropFile", referenced from:<br />
-[SDLAppDelegate application:openFile:] in libSDL.a(SDL_cocoaevents.o)<br />
ld: symbol(s) not found for architecture i386<br />
clang: error: linker command failed with exit code 1 (use -v to see invocation)"<br />
<br />
Maybe the header is not included somewhere?<br />
<br />
Error details:<br />
"Ld build/Debug/coretest normal i386<br />
cd /Users/Rodrigo/Dropbox/workspace/JoyMapper<br />
setenv MACOSX_DEPLOYMENT_TARGET 10.6<br />
/Developer/usr/bin/clang++ -arch i386 -isysroot /Developer/SDKs/MacOSX10.6.sdk -L/Users/Rodrigo/Dropbox/workspace/JoyMapper/build/Debug -L/Users/Rodrigo/Dropbox/workspace/JoyMapper/../dev/SDL-1.3.0-src/Xcode/SDL/build/Development_native_only "-L/Users/Rodrigo/Dropbox/workspace/JoyMapper/../../../Workspace Libs/SDL-1.3.0-src/Xcode/SDL/build/Development_native_only" -F/Users/Rodrigo/Dropbox/workspace/JoyMapper/build/Debug -filelist /Users/Rodrigo/Dropbox/workspace/JoyMapper/build/JoyMapper.build/Debug/coretest.build/Objects-normal/i386/coretest.LinkFileList -mmacosx-version-min=10.6 -framework OpenGL -framework Carbon -framework ForceFeedback -framework AudioUnit -framework CoreAudio -framework CoreAudioKit -framework IOKit -framework Cocoa -framework Foundation -lSDL -o /Users/Rodrigo/Dropbox/workspace/JoyMapper/build/Debug/coretest"<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
<br />
        Sam Lantinga wrote:<br />
<br />
        What was the linker error?  I build regularly on OS X here with everything enabled and haven't seen an issue... ?<br />
<br />
<br />
On Wed, Feb 1, 2012 at 3:11 PM, RodrigoCard <> wrote:<br />
<br />
<br />
<br />
        Quote:<br />
<br />
<br />
                        I got a linker error when building SDL in Xcode with the new drag n drop API enabled.<br />
Since I was not using it I just commented the code and built it normally.<br />
<br />
Now I want to take a look, but dont know what to do.<br />
I need to include some framework or library I dont know?<br />
<br />
thanks!<br />
        <br />
<br />
<br />
<br />
<br />
<br />
_______________________________________________<br />
SDL mailing list<br />
<br />
<a href="http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org" target="_blank">http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org</a><br />
<br />
<br />
        <br />
<br />
<br />
        <br />
<br />
<br />
        <br />
<br />
_______________________________________________<br />
SDL mailing list<br />
<br />
<br />
<a href="http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org" target="_blank">http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org</a><br />
<br />
<br />
        <br />
<br />
<br />
        <br />
<br />
<br />
        <br />
<br />
_______________________________________________<br />
SDL mailing list<br />
<br />
<a href="http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org" target="_blank">http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org</a><br />
<br />
</td><br />         </tr><br /> </table></div></td><br />         </tr><br /> </table></div></div>
        </body>
</html>