<html><head><style type="text/css"><!-- DIV {margin:0px;} --></style></head><body><div style="font-family:times new roman,new york,times,serif;font-size:12pt"><div>Well I tried, it made things advance. Now I get many undefined references to other libs, like png, jpeg (exemple at the end) etc. <br>I used the additional links that I found here : <br><span><a target="_blank" href="http://stackoverflow.com/questions/115813/how-to-statically-compile-an-sdl-game-on-windows">http://stackoverflow.com/questions/115813/how-to-statically-compile-an-sdl-game-on-windows</a></span><br><br>My LDFLAGS is no : <br>LDFLAGS      = -Wl,-Bstatic -lSDL_image `sdl-config --cflags --static-libs` -Wl,-Bdynamic `directfb-config --libs` -lpng12 -ltiff -ljpeg -lasound -laudio -lesd -lpulse-simple -lcaca -laa -ldl<br> <br>Now, I have nearly only a problem with pulse audio. When I don't use the -lpulse-simple lib I get errors like this
 :<br>/usr/lib/libSDL.a(SDL_pulseaudio.o): In function `PULSE_CloseAudio':<br>(.text+0x14e): undefined reference to `pa_simple_drain'<br><br>And when I add -lpulse, or -lpulse-simple, it do not find it.<br>/usr/bin/ld: cannot find -lpulse-simple<br><br>But I checked and I do have libpulse ad libpulse-simple in /usr/lib. What can I do?<br>Thx for the help.<br><br>/usr/lib/libSDL_image.a(IMG_jpg.o): In function `IMG_InitJPG':<br>(.text+0x12): undefined reference to `jpeg_calc_output_dimensions'<br>/usr/lib/libSDL_image.a(IMG_jpg.o): In function `IMG_InitJPG':<br>(.text+0x1c): undefined reference to `jpeg_CreateDecompress'<br>/usr/lib/libSDL_image.a(IMG_jpg.o): In function `IMG_InitJPG':<br>(.text+0x26): undefined reference to `jpeg_destroy_decompress'<br>/usr/lib/libSDL_image.a(IMG_jpg.o): In function `IMG_InitJPG':<br>(.text+0x30): undefined reference to `jpeg_finish_decompress'<br>/usr/lib/libSDL_image.a(IMG_jpg.o): In function
 `IMG_InitJPG':<br>(.text+0x3a): undefined reference to `jpeg_read_header'<br>/usr/lib/libSDL_image.a(IMG_jpg.o): In function `IMG_InitJPG':<br>(.text+0x44): undefined reference to `jpeg_read_scanlines'<br>/usr/lib/libSDL_image.a(IMG_jpg.o): In function `IMG_InitJPG':<br>(.text+0x4e): undefined reference to `jpeg_resync_to_restart'<br>/usr/lib/libSDL_image.a(IMG_jpg.o): In function `IMG_InitJPG':<br><br></div><div style="font-family: times new roman,new york,times,serif; font-size: 12pt;"><br><div style="font-family: arial,helvetica,sans-serif; font-size: 13px;"><font face="Tahoma" size="2"><hr size="1"><b><span style="font-weight: bold;">De :</span></b> Mikael Eriksson <mikael_eriksson@miffe.org><br><b><span style="font-weight: bold;">À :</span></b> sdl@lists.libsdl.org<br><b><span style="font-weight: bold;">Envoyé le :</span></b> Jeu 2 décembre 2010, 5h 03min 27s<br><b><span style="font-weight: bold;">Objet :</span></b> Re: [SDL]
 statically linking<br></font><br>On Wed, Dec 01, 2010 at 03:53:32PM +0000, azer tyuiop wrote:<br>> $(TARGET): $(OBJ)<br>>     $(CC) $(LDFLAGS) -o $@ $^<br><br>IIRC the order is important when staticly linking, try:<br>$(TARGET): $(OBJ)<br>    $(CC) -o $@ $^ $(LDFLAGS)<br>_______________________________________________<br>SDL mailing list<br><a ymailto="mailto:SDL@lists.libsdl.org" href="mailto:SDL@lists.libsdl.org">SDL@lists.libsdl.org</a><br><a href="http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org" target="_blank">http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org</a><br></div></div>
</div><br>




      </body></html>