[SDL] Failed to open vchiq device on RPi

Andreas Falkenhahn andreas at falkenhahn.com
Fri Sep 2 09:37:56 PDT 2016


On 01.09.2016 at 20:43 Eric Wing wrote:

> On 9/1/16, Andreas Falkenhahn <andreas at falkenhahn.com> wrote:
>> I've compiled SDL 2.0.4 on my Raspberry Pi 2 (running Raspbian) and followed
>> all
>> the instructions in docs/README-raspberrypi.md. However, it doesn't work. I
>> always
>> get the following error:

>>     * failed to open vchiq device

>> I've googled the error and tried all the solutions I could find (e.g. doing
>> a
>> "sudo chmod 777 /dev/vchiq" or adding user pi to the video group by doing
>> "sudo usermod -a -G video pi") but nothing helped. I still get the error.

>> What is causing this and how can I fix this?


> I'm assuming you are using Raspbian Jessie.

I'm still on Wheezy but AFAIR that should be ok.

> I don't remember having to do anything special on my Pi that required
> privileged access (besides cranking up the amount of GPU memory). But
> I have a pretty boring Pi setup. (Just the basic with a HDMI into a
> TV. No cameras or touch screen, etc.)

> Does my demo program work for you?
> http://playcontrol.net/tempdownload/BlurrrBinaries/FlappyBlurrrC-0.1.1-Raspbian.tar.gz

Yes, it works. What could be the reason that my build doesn't work?

-- 
Best regards,
 Andreas Falkenhahn                            mailto:andreas at falkenhahn.com



More information about the SDL mailing list