[SDL] small fix for OpenGL support on X11 when only GLES2 is available (not GLES1)

Eleni Maria S. elene.mst at gmail.com
Thu Mar 28 13:08:22 PDT 2013


Thanks a lot, "sudo apt-get install x11proto-core-dev" helped me

On Tue, Mar 12, 2013 at 8:50 PM, Edward Rudd <urkle at outoforder.cc> wrote:
> Here is a deb bug about the issue.
>
> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=649866
>
> On Mar 12, 2013, at 13:28 , Alexey Petruchik wrote:
>
>> Hi, all. I'm trying to comile SDL2.0 on Debian 6.0 and I'm getting
>> tons of identical errors (error: expected declaration specifiers or
>> '...' before X)  in gl.h and x11 headers when compiling
>> SDL_x11clipboard.c. Full error log here:
>> https://dl.dropbox.com/u/1777581/sdl_debian_error_log.txt (too long to
>> paste in mail). I have no idea what can cause such errors so help from
>> experienced linux guys will be really appreciated.
>>
>> Thanks in advance
>> Regards, Alexey
>> _______________________________________________
>> SDL mailing list
>> SDL at lists.libsdl.org
>> http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org
>
> Edward Rudd
> OutOfOrder.cc
> Skype: outoforder_cc
> 317-674-3296
>
>
>
>
>
>
> _______________________________________________
> SDL mailing list
> SDL at lists.libsdl.org
> http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org



More information about the SDL mailing list