[SDL] Drag n drop API linker error.

Sam Lantinga slouken at libsdl.org
Thu Feb 9 18:55:49 PST 2012


Great, good luck with your deadline! :)

On Thu, Feb 9, 2012 at 9:26 AM, RodrigoCard <cuecax at gmail.com> wrote:

> **
> It is some weeks old, I will update and check if it works as soon as I
> have time.
> Not now, because I can't risk break anything in my personal project in the
> next weeks, it is approaching my deadline =]
>
>
>
>
>  Sam Lantinga wrote:
>
>  That's weird.  Are you using the latest official project?
>
>
>
> On Wed, Feb 8, 2012 at 7:48 PM, RodrigoCard <> wrote:
>
>
>
>  Quote:
>
>  In fact, this problem was happening just with the static library, the
> framework version worked just fine.
> And Yes, it was not linking to the .o file.
> The fix was pretty simple, I just included the "SDL_dropevents.c" in the
> static library target, it was not there, ha! Silly like this. =D
>
> But I still cant drop anything to my app, I need to change something in
> the app's plist?
>
>
>
>
>
> Sam Lantinga wrote:
>
> That's very strange.  If you look at the static library build step, it
> builds SDL_dropevents.c, and it's not very complicated, it's just one
> function - the one that it can't find for some reason...
>
> Can you look at the link line and make sure it's linking that .o file?
>
>
> On Mon, Feb 6, 2012 at 11:24 AM, RodrigoCard <> wrote:
>
>
>
> Quote:
>
> The library itself is builds just fine, but I got a error when linking SDL
> static library in my application.
> I included every framework included by SDL, and it works without
> senddropfile, so I dont know what more to do for now.
>
> I am using Xcode 4.1 on OSX Lion 10.7.2, and using a revision from a bit
> before the SDL2 rename.
>
> Here is the error:
>
> "Undefined symbols for architecture i386:
> _SDL_SendDropFile", referenced from:
> -[SDLAppDelegate application:openFile:] in libSDL.a(SDL_cocoaevents.o)
> ld: symbol(s) not found for architecture i386
> clang: error: linker command failed with exit code 1 (use -v to see
> invocation)"
>
> Maybe the header is not included somewhere?
>
> Error details:
> "Ld build/Debug/coretest normal i386
> cd /Users/Rodrigo/Dropbox/workspace/JoyMapper
> setenv MACOSX_DEPLOYMENT_TARGET 10.6
> /Developer/usr/bin/clang++ -arch i386 -isysroot
> /Developer/SDKs/MacOSX10.6.sdk
> -L/Users/Rodrigo/Dropbox/workspace/JoyMapper/build/Debug
> -L/Users/Rodrigo/Dropbox/workspace/JoyMapper/../dev/SDL-1.3.0-src/Xcode/SDL/build/Development_native_only
> "-L/Users/Rodrigo/Dropbox/workspace/JoyMapper/../../../Workspace
> Libs/SDL-1.3.0-src/Xcode/SDL/build/Development_native_only"
> -F/Users/Rodrigo/Dropbox/workspace/JoyMapper/build/Debug -filelist
> /Users/Rodrigo/Dropbox/workspace/JoyMapper/build/JoyMapper.build/Debug/coretest.build/Objects-normal/i386/coretest.LinkFileList
> -mmacosx-version-min=10.6 -framework OpenGL -framework Carbon -framework
> ForceFeedback -framework AudioUnit -framework CoreAudio -framework
> CoreAudioKit -framework IOKit -framework Cocoa -framework Foundation -lSDL
> -o /Users/Rodrigo/Dropbox/workspace/JoyMapper/build/Debug/coretest"
>
>
>
>
>
>
>
>
> Sam Lantinga wrote:
>
> What was the linker error?  I build regularly on OS X here with everything
> enabled and haven't seen an issue... ?
>
>
> On Wed, Feb 1, 2012 at 3:11 PM, RodrigoCard <> wrote:
>
>
>
> Quote:
>
>
> I got a linker error when building SDL in Xcode with the new drag n drop
> API enabled.
> Since I was not using it I just commented the code and built it normally.
>
> Now I want to take a look, but dont know what to do.
> I need to include some framework or library I dont know?
>
> thanks!
>
>
>
>
>
>
> _______________________________________________
> SDL mailing list
>
> http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org
>
>
>
>
>
>
>
>
>
>
> _______________________________________________
> SDL mailing list
>
>
> http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org
>
>
>
>
>
>
>
>
>
>
> _______________________________________________
> SDL mailing list
>
> http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org
>
>
>
>
>
>
> _______________________________________________
> SDL mailing list
> SDL at lists.libsdl.org
> http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.libsdl.org/pipermail/sdl-libsdl.org/attachments/20120209/014d8bc4/attachment-0008.htm>


More information about the SDL mailing list