[SDL] SDL 1.3 status ?

Tim Angus tim at ngus.net
Thu Jul 28 03:43:44 PDT 2011


On 28/07/2011 00:19, Bob Pendleton wrote:
> I think that pulling the compat layer would speed development by
> freeing use from any need to stay compatible with 1.2. Right now every
> time anyone thinks of a change or addition you have to think "How will
> this effect compatibility?"

I don't necessarily think the compatibility layer should be removed as 
you do, but I do agree that any new APIs should not be comprimised in 
order to improve compatibility.

Also, while I don't advocate its removal, I do think that the 
compatibility layer should not be enabled by default. When doing 1.3/2.0 
stuff now I routinely have to define SDL_NO_COMPAT somewhere in order to 
ensure I'm building against the correct API. It should be opt in, not 
opt out.




More information about the SDL mailing list