[SDL] SDL_image on OS X 10.7(Lion), xcode 4.1 Re: Please test the latest 1.2 from Mercurial on Mac OS X...

Eric Wing ewmailing at gmail.com
Thu Jul 28 01:59:07 PDT 2011


On 7/28/11, Ryan C. Gordon <icculus at icculus.org> wrote:
>
>> Interesting. Any place I can find specific details on this? Do you
>> know when and how this breakage was introduced? (e.g. was it Xcode 4,
>> llvm, a OS X system update, 64-bit only, Intel only, etc.) I recall
>> being able to (mostly) build using the 10.6 SDK for 10.5, with the
>> most public major roadblock being Apple screwed up the backwards
>> compatibility linkage for libcrypto. If you didn't need libcrypto, you
>> were mostly fine.
>
> I'm shaky on the details, but I first started seeing it in Xcode 3 last
> year, if you linked against the latest SDK instead of 10.whatever. This
> was with gcc, not clang (but I assume it's a function of the linker, not
> the compiler). I can dig you up the actual error message tomorrow.
>
> It's entirely possible this can work, and we just screwed something up
> on our side.

I wouldn't be surprised if you found another Apple problem. I was just
curious as to what it is in case I need to deal with it in the future.

For what it's worth (not much I'm sure), the binary release of
LuaCocoa v0.3 I just put out this week was built on Snow Leopard under
Xcode 3.2.5 using the "Current SDK" and min OS set to 10.5. I build a
3-way Universal Binary (Intel 32/64, PowerPC 32) and the binaries work
on my PowerPC 12" Powerbook running 10.5. But I have not tried Intel
on 10.5. (All Intel machines I encounter are running 10.6 or 10.7.)

Thanks,
Eric
-- 
Beginning iPhone Games Development
http://playcontrol.net/iphonegamebook/



More information about the SDL mailing list