[SDL] Has anyone published an SDL 1.3 app on the Mac App Store?

VernJensen vern at actionsoft.com
Sun Jul 24 14:47:31 PDT 2011


Brian Barnes wrote:
> Vern -- is it the archiver that's causing you the problem?  The archiver is completely and utterly broken, and it's no better in 4.1.
> 
> If this is your problem, use the project build command line tool:
> 
> productbuild --component VERN.app /Applications --sign "3rd Party Mac Developer Installer: VERN" VERN.pkg
> 
> Then use application loader (it'll be in your development package) to upload it.
> 
> Scruffy3D (everybody go and look!) is up in the App Store right now!
> 
> [>] Brian
> 
> No, I've tried using both XCode and productbuild to submit. I get the same error in the end. Something about the SDL.framework not being declared in packageInfo or something like that. Apple has a FAQ about this on their forums -- that it means multiple frameworks are using the same Bundle Identifier, but this is no the case. I've tried all sort of variations for different bundle identifiers for the SDL.framework, but none work.
> 
> I'm guessing Scruffy3D uses SDL 1.2.x. I'm using SDL 1.3. So far I've heard from no one who has used SDL 1.3 to get an app on the Mac App Store.
> _______________________________________________
> SDL mailing list
> SDL at lists.libsdl.org
> http://lists.libsdl.org/listinfo.cgi/sdl-libsdl.org





-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.libsdl.org/pipermail/sdl-libsdl.org/attachments/20110724/9afb1e1b/attachment-0008.htm>


More information about the SDL mailing list