[SDL] Can't set any OpenGL video mode on OpenSUSE 10.1 64 bit

karx11erx karx11erx at hotmail.com
Sat Sep 16 15:56:48 PDT 2006


DARKGuy . <dark.guy.2008 <at> gmail.com> writes:

> 
> 
> I don't know much but... shouldn't you use your video card's driver instead of
the "generic" ones?
> 
> On 9/16/06, karx11erx <
> karx11erx <at> hotmail.com> wrote:Torsten Giebl <wizard <at> 
> syntheticsw.com> writes:>> Hello !>> > I am trying to run an OpenGL
application using SDL 1.2.11 on OpenSUSE> > 10.1 64> > bit, but SDL fails to set
any reasonable video mode on my system (like
> > > 640x480x32 windowed/fullscreen, or 1152x768x24 (X11 setting)).> >> >> > I
have a Radeon X800 XT PE installed.> >> >> > The application runs fine on MS
Windows, Mac OS X and 32 bit Linux.
> >> What about other OpenGL apps under OpenSUSE ?> What says glxinfo ?>>
CU>OpenGL vendor string: Mesa project: www.mesa3d.orgOpenGL renderer string:
Mesa GLX Indirect
> OpenGL version string: 1.2 (1.5 Mesa 6.4.1)OpenGL
extensions:    GL_ARB_imaging, GL_ARB_multitexture,
GL_ARB_texture_border_clamp,    GL_ARB_texture_cube_map,
GL_ARB_texture_env_add,    GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
>     GL_ARB_transpose_matrix, GL_EXT_abgr,
GL_EXT_blend_color,    GL_EXT_blend_minmax, GL_EXT_blend_subtract,
GL_EXT_texture_env_add,    GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3,    GL_EXT_texture_lod_bias
>    visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav id dep
cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b
eat----------------------------------------------------------------------
> 0x23 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  1 0 None0x24 24
tc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  1 0 None0x25 24 tc  0
32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None
> 0x26 24 tc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None0x27 24
dc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  1 0 None0x28 24 dc  0
24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  1 0 None
> 0x29 24 dc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  1 0 None0x2a 24
dc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  1 0 NoneThat MESA only
returns OpenGL version 1.2 bothers me.
:(_______________________________________________SDL mailing listSDL <at>
libsdl.orghttp://www.libsdl.org/mailman/listinfo/sdl
> 
> 
> 
> 
> 
> 
> _______________________________________________
> SDL mailing list
> SDL <at> libsdl.org
> http://www.libsdl.org/mailman/listinfo/sdl
> 


What is telling you I am not using the ATI drivers?





More information about the SDL mailing list