[SDL] No Sound Output

John Popplewell john at johnnypops.demon.co.uk
Thu Nov 3 14:40:36 PST 2005


On Thu, Nov 03, 2005 at 11:05:00AM -0500, Timm Murray wrote:
> On Thursday 03 November 2005 03:56 am, John Popplewell wrote:
> <>
> > Here I meant for you to use the path from the above output which would
> > be:
> >
> > ldd  /usr/local/lib/libSDL_mixer-1.2.so.0
> >
> > I'm just trying to confirm that the libSDL_mixer that you are using is
> > linked to the same libSDL that your app is using.
> 
> Ahh, I see here now:
> 
> $ ldd /usr/local/lib/libSDL_mixer-1.2.so.0        linux-gate.so.1 =>  
> (0xffffe000)
>  libvorbisfile.so.3 => /usr/lib/libvorbisfile.so.3 (0xb7f84000)
>  libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0xb7f5c000)
>  libogg.so.0 => /usr/lib/libogg.so.0 (0xb7f57000)
>  libSDL-1.2.so.0 => /usr/local/lib/libSDL-1.2.so.0 (0xb7ebc000)
>  libpthread.so.0 => /lib/libpthread.so.0 (0xb7e6a000)
>  libc.so.6 => /lib/libc.so.6 (0xb7d52000)
>  libm.so.6 => /lib/libm.so.6 (0xb7d2e000)
>  libdl.so.2 => /lib/libdl.so.2 (0xb7d2a000)
>  libX11.so.6 => /usr/lib/libX11.so.6 (0xb7c5e000)
>  libXext.so.6 => /usr/lib/libXext.so.6 (0xb7c50000)
>  /lib/ld-linux.so.2 (0x80000000)

Hmm. No joy there. Both using the same version of libSDL.
I've recently updated so I'm using libsdl-1.2.9-r1 and
sdl-mixer-1.2.6-r1. I've got an environment variable set:

export SDL_AUDIODRIVER=alsa

Also, if you've built SDL_mixer from source, you should find 2 test
programs: playwave and playmus in the SDL_mixer-1.2.6 source directory.
What do these programs do?

If you've built SDL itself from source then have a look in the 'test'
source directory and run configure then make to build the example
programs. The loopwave program reports what sound driver is in use.

What about other audio files, do they work?

Good Luck,

cheers,
John.

> _______________________________________________
> SDL mailing list
> SDL at libsdl.org
> http://www.libsdl.org/mailman/listinfo/sdl





More information about the SDL mailing list