[SDL] Problem with rendertargets (no output/video)

Anthony DeChiaro ktulu1115 at yahoo.com
Wed Jan 26 12:58:34 PST 2005


You're correct, only testgl and testrendertargets link to libGL.so -
so it must be the problem.  I also found someone else has/had the
same problem on the NVIDIA linux forums:

http://www.nvnews.net/vbulletin/showthread.php?t=42939

I ran ldd on the original XMMS visualization and discovered it linked
to libGL.so as well, so this is all starting to make sense now.  I
also searched my system for packages/references to libGL.so:

ktulu at eternal:~/SDL-1.3.0/test $ dpkg -S libGL.so
xlibmesa-gl-dev: /usr/lib/libGL.so
diversion by nvidia-glx from: /usr/X11R6/lib/libGL.so.1
diversion by nvidia-glx to: /usr/X11R6/lib/nvidia/libGL.so.1.xlibmesa
diversion by nvidia-glx from: /usr/lib/libGL.so.1
diversion by nvidia-glx to: /usr/lib/nvidia/libGL.so.1.xlibmesa
nvidia-glx, xlibmesa-gl: /usr/lib/libGL.so.1
diversion by nvidia-glx from: /usr/X11R6/lib/libGL.so.1
diversion by nvidia-glx to: /usr/X11R6/lib/nvidia/libGL.so.1.xlibmesa
xlibmesa-gl: /usr/X11R6/lib/libGL.so.1
diversion by nvidia-glx from: /usr/lib/libGL.so.1.2
diversion by nvidia-glx to: /usr/lib/nvidia/libGL.so.1.2.xlibmesa
diversion by nvidia-glx from: /usr/lib/libGL.so.1
diversion by nvidia-glx to: /usr/lib/nvidia/libGL.so.1.xlibmesa
diversion by nvidia-glx from: /usr/X11R6/lib/libGL.so.1.2
diversion by nvidia-glx to:
/usr/X11R6/lib/nvidia/libGL.so.1.2.xlibmesa
diversion by nvidia-glx from: /usr/X11R6/lib/libGL.so.1.2
diversion by nvidia-glx to:
/usr/X11R6/lib/nvidia/libGL.so.1.2.xlibmesa
xlibmesa-gl: /usr/X11R6/lib/libGL.so.1.2
diversion by nvidia-glx from: /usr/lib/libGL.so.1.2
diversion by nvidia-glx to: /usr/lib/nvidia/libGL.so.1.2.xlibmesa
xlibmesa-gl: /usr/lib/libGL.so.1.2
nvidia-glx: /usr/lib/libGL.so.1.0.6111
xlibmesa-gl-dev: /usr/X11R6/lib/libGL.so

Any ideas?  Thank you for your time.

-Anthony


--- Stephane Marchesin <stephane.marchesin at wanadoo.fr> wrote:

> Anthony DeChiaro wrote:
> 
> >Actually, no OpenGL apps work fine - Xscreensaver works without
> any
> >problems, I can play games that use OpenGL without any
> difficulties -
> >it only seems to be the render targets functionality that isn't
> >working.
> >
> testgl doesn't use render targets, while you mentioned that it
> doesn't 
> work. So there is probably a problem somewhere. I thing you might
> have 
> another libGL hanging somewhere in your system. Do a ldd on the
> binary 
> files and see if they always point to the same libGL.so.
> 
> Stephane
> 
> 
> 
> 
> _______________________________________________
> SDL mailing list
> SDL at libsdl.org
> http://www.libsdl.org/mailman/listinfo/sdl
> 





More information about the SDL mailing list