[SDL] SDL opengl stopped working

Jimmy Karlsson jimmy.karlsson at nempo.net
Sun Nov 30 10:38:00 PST 2003


OK, I feel really stupid now, it turns out that the core problem was 
lack of support for X in libsdl, ie. I had forgotten to compile in 
support for it. Well, the hardest of problems often has the simpliest of 
solutions...or something like that anyway.

-JK

Alexander Bussman wrote:
> Oh, so every OpenGL application except the SDL OpenGL applications do work?
> hmmm... if so, I can't tell you what's wrong.
> I'm running Linux 2.6-test10 but with a nvidia card and it works fine.
> 
> 
> Jimmy Karlsson wrote:
> 
>> I trust that the package management system (portage) installed it 
>> correctly but I'll do some checking. Can it be that I'm running the 
>> 2.6 (some test version) thatäs messing things up. It's just that the 
>> only thing that's not working is SDL opengl, q3, nwn and glut apps 
>> works just fine so I know that opengl in general works.
>>
>> Alexander Bussman wrote:
>>
>>> You haven't installed your graphics card correctly.
>>> Install the drivers from ati and it should work, I don't have any ati 
>>> card so I can't tell you how to install them but there should be a 
>>> document for that.
>>> btw, ATI is not known to have good Linux support (but hopefully it 
>>> will be better soon).
>>>
>>>
>>> Jimmy Karlsson wrote:
>>>
>>>> As the topic says sdl opengl stopped working after I switch my gfx 
>>>> card from a nvidia g3ti200 to a ati radeon 9600. This is most likely 
>>>> a driver issue but I have no idea how to fix it. As far as I know 
>>>> both the ati- and nvidia-drivers have hardware accel. opengl support.
>>>>
>>>> I've tested other SDL opengl apps and they all seem to suffer from 
>>>> this problem. It would kinda suck if you had to have a nvidia gfx 
>>>> card to be able to get opengl support in SDL under linux(dist is 
>>>> gentoo btw.).
>>>>
>>>> The error message I'm getting is 'Unable to init SDL: No available 
>>>> video device' generated by your standard init code. My application 
>>>> had no trouble running on the g3ti200, any ideas ?
>>>>
>>>> -JK
>>>>
>>>>
>>>> _______________________________________________
>>>> SDL mailing list
>>>> SDL at libsdl.org
>>>> http://www.libsdl.org/mailman/listinfo/sdl
>>>>
>>>
>>>
>>>
>>> _______________________________________________
>>> SDL mailing list
>>> SDL at libsdl.org
>>> http://www.libsdl.org/mailman/listinfo/sdl
>>
>>
>>
>>
>> _______________________________________________
>> SDL mailing list
>> SDL at libsdl.org
>> http://www.libsdl.org/mailman/listinfo/sdl
>>
> 
> 
> 
> _______________________________________________
> SDL mailing list
> SDL at libsdl.org
> http://www.libsdl.org/mailman/listinfo/sdl





More information about the SDL mailing list