[SDL] Mac OS X CodeWarrior linking woes

Dave Beck davethebrv at crystalpiersw.com
Mon Nov 3 16:19:01 PST 2003


I'm trying to port my Win32 SDL app over to Mac OS X. I own the latest
CodeWarrior, which is what I'm using to compile on both platforms. My
problem is that I am running into some link errors on OS X that I have not
been able to resolve.

The errors are undefined function errors. Specifically, all the public
functions of the add on libs I am using (IMG, mixer, and TTF) that are
referenced in my app are reported to by undefined. The SDL functions,
however, are linking without problems.

I have included the SDL framework, as well as the frameworks for the add on
libs in my Mach-O project. The SDL framework is included first, but
strangely, if I reverse the order (include an add-on framework before the
SDL framework), CW hangs stalled during link and I have to force quit.

I tried building the add on frameworks myself using CW, and I got them to
build but I had the exact same result when I tried to link my app.

Is there a step I am missing here? This is my first attempt to compile a
Mach-O executable that uses non-standard frameworks. Perhaps something
elementary I overlooked?

Any help would be greatly appreciated.

Thanks,
Dave





More information about the SDL mailing list