[SDL] Error compiling SDL 1.2.5 with MinGW

Guido Draheim guidod-2003- at gmx.de
Thu Jan 2 18:25:00 PST 2003


Guido Draheim wrote:
> Matt Borkowski wrote:
> 
>> I just downloaded and installed the latest bundle
>> release of MinGW (2.0.0) and MSYS (1.0.8), and both
>> seem to work fine, except when trying to compile SDL
>> 1.2.5. It was ok for a quite a while, but then it
>> stopped with this error:
>>
>>  dlltool --as=as --dllname SDL.dll --exclude-symbols
>> _DllMain at 12,_cygwin_dll_entry at 12,_cygwin_noncygwin_dll_entry at 12
>> --def .libs/SDL.dll-def --base-file .libs/SDL.dll-base
>> --output-exp .libs/SDL.dll-exp
>> c:\mingw\bin\dlltool.exe: installation problem, cannot
>> exec `as'
>> make[2]: *** [libSDL.la] Error 1
>> make[2]: Leaving directory `/c/SDL-1.2.5/src'
>> make[1]: *** [all-recursive] Error 1
>> make[1]: Leaving directory `/c/SDL-1.2.5/src'
>> make: *** [all-recursive] Error 1
>>
>> ---
>>
>> I have no clue how to deal with this. 'as' is present,
>> and my mingw/bin is in the path (I think that's the
>> right term) as I can run 'as' from anywhere.
>> Thanks.
>> - Matt Borkowski
>>
> 
> did you "move" the `as`??? I well guess that the dlltool has
> hardcoded the path to the `as` and it is not sufficient to
> just have it in path. Lookup the full path to the `as` that
> is currently working for you, and use the dlltool option to
> hand it over to `dlltool --as <name>`. See what it says and
> guess what's wrong.... ;-) ... have fun, guido
> 

Just thought about it for another second - isn't it that dlltool
is called trough libtool here? Is that a problem to be taken to
the mingw mailinglist? Anyway, just wild guessing - have fun, guido







More information about the SDL mailing list