[SDL] Problems with SDL and Slackware 8.1

sean whalen lucidity at gmx.net
Wed Jul 31 21:49:00 PDT 2002


i don't have a solution for you, but i just set up sdl with slack 8.1 yesterday and it's compiling/running my apps fine.
    -sean
  ----- Original Message ----- 
  From: niklas bolander 
  To: sdl at libsdl.org 
  Sent: Wednesday, July 31, 2002 2:04 PM
  Subject: [SDL] Problems with SDL and Slackware 8.1


  Has anybody else out there managed to get this combo working?
  I installed the SDL without any errors but I can't complile any applications.
  When running configure for the tests i recieve the following message:

  checking for SDL - version >= 1.2.3... no
  *** Could not run SDL test program, checking why...
  *** The test program compiled, but did not run. This usually means
  *** that the run-time linker is not finding SDL or finding the wrong
  *** version of SDL. If it is not finding SDL, you'll need to set your
  *** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
  *** to the installed location Also, make sure you have run ldconfig if that
  *** is required on your system
  ***
  *** If you have an old version installed, it is best to remove it, although
  *** you may also be able to get things to work by modifying LD_LIBRARY_PATH
  configure: error: *** SDL version 1.2.3 not found!

  I installed the library at /usr/local/lib (is included in /etc/ld.so.conf), i have run ldconfig and i've tried setting up LD_LIBRARY_PATH to /usr/local/lib

  after checking out the faqs I removed the config.cache files and made sure that there wheren't any old SDL versions hiding in some dark corner of my fs.

  finally some more info...

  which sdl-config
  /usr/local/bin/sdl-config
  sdl-config --version
  1.2.4
  locate libSDL
  /usr/local/games/tuxracer-demo/libSDL-1.2.so.0
  /usr/local/games/tuxracer-demo/libSDL_mixer-1.2.so.0
  /usr/local/lib/libSDLmain.a
  /usr/local/lib/libSDL-1.2.so.0.0.4
  /usr/local/lib/libSDL-1.2.so.0
  /usr/local/lib/libSDL.so
  /usr/local/lib/libSDL.la
  /usr/local/lib/libSDL.a
  /root/SDL-1.2.4/src/main/libSDLmain.a
  /root/SDL-1.2.4/src/.libs/libSDL-1.2.so.0.0.4
  /root/SDL-1.2.4/src/.libs/libSDL-1.2.so.0
  /root/SDL-1.2.4/src/.libs/libSDL.so
  /root/SDL-1.2.4/src/.libs/libSDL.lai
  /root/SDL-1.2.4/src/.libs/libSDL.a
  /root/SDL-1.2.4/src/.libs/libSDL.la
  /root/SDL-1.2.4/src/libSDL.la
  tail config.log

  #define PACKAGE_NAME ""
  #define PACKAGE_TARNAME ""
  #define PACKAGE_VERSION ""
  #define PACKAGE_STRING ""
  #define PACKAGE_BUGREPORT ""
  #define PACKAGE "SDL_tests"
  #define VERSION "1.2.3"

  configure: exit 1

  Gratefull for all/any help :) 
  _______________________________________________________________
  Be Unique! Get your personalized email address at www.NamePlanet.com



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.libsdl.org/pipermail/sdl-libsdl.org/attachments/20020731/c4013064/attachment-0008.htm>


More information about the SDL mailing list