[SDL] Cannot include SDL properly

Dinand Vanvelzen vanvelzen at skynet.be
Fri Jul 26 04:21:01 PDT 2002


Carsten Ziepke wrote:

> On Fri, 26 Jul 2002 11:34:05 +0200
> Dinand Vanvelzen <vanvelzen at skynet.be> wrote:
> 
>> Here's my first problem w00t :)
>> 
>> i have SDL in my redhat distribution, so i did #include <SDL/SDL.h>
>> but no luck, it will accept the include but it wont recognize any of
>> the SDL identifyers. Next i copied all SDL code into a sub dir of my
>> project ( SDL) and there i made 2 sub's src and include. copied all
>> the files till all includes where satiesfied. And i got the same thing
>> again,.. it won't recognize any SDL identifyers nor any OpenGL ones.
>> 
>> I use KDevelop 2.1
> 
> Maybe this works ( I use the german version of KDevelop - some items
> maybe called others in your version )::
> In KDevelop goto Project->Options ( F7 )
> Goto Compiler Options ( 2nd from top ) -> Other options ( a text field ):
> Put in there: 'sdl-config --libs' 'sdl-config --cflags`
> 
> Bye,
> Carsten

Options was the configure tab at compiler options, there at the bottom was a 
input field called additional options. there i entered 

'sdl-config --libs' 'sdl-config --cflags`

and pressed ok
this is what the compiler said :

Running configure in source directory 
configure: warning: sdl-config --libs: invalid host type 
configure: warning: sdl-config --cflags: invalid host type 
configure: error: can only configure for one host and one target at a time 
*** failed *** 

Any idea's ?

DV

~kicking the win32 habbit :)



More information about the SDL mailing list