[SDL] A Quick libGL question..

Joseph Carter knghtbrd at bluecherry.net
Sat Jul 6 10:40:01 PDT 2002


On Sat, Jul 06, 2002 at 12:52:23PM +0000, Jason Farmer wrote:
> here's the deal, When I try to run an OpenGL application (eg Quake2 with 
> OpenGL glx) they complain bitterly that libGL.so.1 could not be found yet the 
> file clearly exists on my system as a sym link in the usr/lib directory. 
> But it doesn't exist in the usr/X11R6 directory
> 
> The PC is a SuSE 8.0 Linux box , Recent install.
> 
> Here's the most important part...
> When I try to compile sdl-1.2.4, one of the messages displayed by ./configure 
> is 
> checking for OpenGL (GLX) support... no
> 
> I can only assume that this is related.

Do you have /usr/lib/libGL.so ?  You need that for compiling.

Id's Quake 2 looked for opengl32.dll and will look for the file in the
directory Quake 2 is installed in for it.  Suggest linking that to
libGL.  I suspect relnev's Quake2 (found on icculus.org) will not have
this problem.

-- 
Joseph Carter <knghtbrd at bluecherry.net>              glDisable (DX8_CRAP);
 
* Caytln slaps Lisa
<Caytln> catfight :P
<LisaHere> Watch it girl, I like that.
<LisaHere> :)
<Caytln> figures :D

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 273 bytes
Desc: not available
URL: <http://lists.libsdl.org/pipermail/sdl-libsdl.org/attachments/20020706/97726b73/attachment-0008.pgp>


More information about the SDL mailing list