[SDL] smpeg/glmovie crawls

Loren Osborn linux_dr at yahoo.com
Wed Jul 3 17:30:02 PDT 2002


Are you perhaps using SDL_mixer?

There is a problem if you don't tell smpeg that it's
supposed to use SDL_mixer... it's trying to sync with
the audio, but unless it's configured properly, it
doensn't know if/when the audio is playing...

look in : smpeg-0.4.3/README.SDL_mixer

that might help...

-Loren

--- Gib Bogle <bogle at ihug.co.nz> wrote:
> 
> There are two issues involved here, which may or may
> not stem from the
> same basic cause:
> 1. The callback to do the OpenGL drawing doesn't
> work, and the draw
> function has to be in the main thread.
> 2. With the draw function in the main thread,
> performance is abysmal.
> 
> As far as I know, the only OpenGL functions used are
> in the draw
> function, which is executing at a great rate, taking
> only 5 ms. 
> Therefore the performance problem seems unrelated to
> OpenGL.  The
> problem is that the draw function is repeatedly
> drawing the same frame,
> since the frame is not getting updated - an smpeg
> problem.
> 
> I am willing to accept Sam's invitation, and delve
> into this.  This
> might not achieve the desired result though, because
> I (a) have no C++
> experience (b) have no game programming experience
> (c) have virtually no
> thread programming experience and (d) am over 50. 
> So don't hold your
> breath.  One thing - it is bound to be educational.
> 
> Gib
> 
> _______________________________________________
> SDL mailing list
> SDL at libsdl.org
> http://www.libsdl.org/mailman/listinfo/sdl


__________________________________________________
Do You Yahoo!?
Sign up for SBC Yahoo! Dial - First Month Free
http://sbc.yahoo.com




More information about the SDL mailing list