[SDL] Visual Studio 6, C++, SDL

Mike Arnold mike at midkaemia.fsnet.co.uk
Sun Aug 26 11:31:01 PDT 2001


Its OK, 

I was banging my head against the wall all night, but eventually was 
inspired to look through the /usr/lib/*.so files for something that had the 
symbol F97ostream or some such... can't quite remember what exactly.

When I found one with this symbol I looked at what the library was linked 
to and looked for anything I wasn't linking to..

turned out to be /usr/lib/libstdc++-libc6.2-2.so.3 

Still can't claim to fully understand it, but I found it and it now work...

Cheers

Mike Arnold wrote:

> Brad LaFountain wrote:
> 
> Brad (or indeed anyone who happens to be listening!),
> 
> I have exactly the same problem on Linux. If I compile a standard SDL app
> using KDevelop and a "C program" everything works fine. When I move to a
> C++ program I get the same errors as you did (although they display
> different text!).
> 
> Could you just clarify exactly which solution fixed it and I will try and
> replicate this on Linux.
> 
> To clarify the position,
> 
> I have tried
> 
> <iostream.h> and cout <<
> <iostream> and using namespace std;
> <iostream> and std::cout
> 
> None of them have fixed it. If I remove the -lSDL and comment out the SDL
> references everything compiles fine - but that sort of defeats the object!
> 
> Thanks in advance for any help, but I have just resigned myself to another
> head banging night for a VERY simple port from C to C++...
> 
> Mike
> 





More information about the SDL mailing list