[SDL] SDL for Mac OS X

John Stone johns at ks.uiuc.edu
Wed Apr 11 07:42:14 PDT 2001


Hi,
  You'll need to add -framework AGL to your link line, something like
this ought to work ok:
  -lSDL -framework OpenGL -framework AGL -framework Carbon

I'm still trying to resolve a problem I'm having on MacOS-X, when
I call the gluNewQuadric() routine inside of a small SDL program
it crashes.  If I do the same thing inside of a GLUT program, it
works fine.  I don't know why yet.  I don't even have to _USE_ the
quadric, just calling gluNewQuadric() will do it.  Another interesting
thing is that calling the other gluxxx() routines apparently works fine.
If anyone has a clue on that, I'd like to hear about it...

  John Stone
  johns at ks.uiuc.edu

On Wed, Apr 11, 2001 at 07:38:10AM -0500, Matt Majka wrote:
> Hi,
> 
> I've got an application port for Mac OS X that can use either
> OpenGL or SDL.  I've got the OpenGL portion working and now
> I'm trying to get the SDL part working.  I downloaded and
> built SDL-1.2.0 using the "./configure ; make" method.  However,
> when I try to link with the resulting SDL library I get a few
> unresolved symbols (aglSwapBuffers, aglShowDrawable, etc).
> I was hoping someone familiar with SDL on the Mac might
> be able to tell me where these "agl" functions reside.
> 
> Thanks,
> 
> Matt

-- 
NIH Resource for Macromolecular Modeling and Bioinformatics
Beckman Institute for Advanced Science and Technology
University of Illinois, 405 N. Mathews Ave, Urbana, IL 61801
Email: johns at ks.uiuc.edu                 Phone: 217-244-3349              
  WWW: http://www.ks.uiuc.edu/~johns/      Fax: 217-244-6078



More information about the SDL mailing list