[SDL] Video problem

Danilo Castro fastjack at fjack.org
Fri Apr 6 15:56:54 PDT 2001


Well im having this problem trying to run dgen ( that the sdl website said
tahts is 100% ok ) 

Im runing 
slackware 7.1
linux kernel 2.4.3
SDL 1.2.0
dgen-sdl 1.22
egcs 2.91.66

Following the FAQ instruction i tried this

[root at dantrius:~] # DISPLAY=:0 ; export DISPLAY
[root at dantrius:~] # dgen files/TOEJAM~1.BIN
rc: Couldn't open rc file /root/.dgen/dgenrc, trying to create
rc: Couldn't create rc file /root/.dgen/dgenrc!
sdl: Couldn't init SDL: No available video device!
main: Couldn't initialize graphics!
[root at dantrius:~] # xhost + localhost
xhost:  unable to open display ":0"
[root at dantrius:~] # dgen files/TOEJAM~1.BIN
rc: Couldn't open rc file /root/.dgen/dgenrc, trying to create
rc: Couldn't create rc file /root/.dgen/dgenrc!
sdl: Couldn't init SDL: No available video device!
main: Couldn't initialize graphics!
[root at dantrius:~] #

running on X ive this problem :

[fastjack at dantrius:~] $ DISPLAY=:0 ; export DISPLAY
[fastjack at dantrius:~] $ xhost + localhost
localhost being added to access control list
[fastjack at dantrius:~] $ dgen files/TOEJAM~1.BIN
Fatal signal: Segmentation Fault (SDL Parachute Deployed)


Can you pls help me with this problem?


Danilo Castro

---------------------------------------
Planetarion 
GC of 57:25
Eclipse Alliance 
Brothethood WC
---------------------------------------
PGP Code : Expired, brb, asap
Email    : fastjack at fjack.org
ICQ      : 467805
---------------------------------------

"It's a damn poor mind that can only n\
think of one way to spell a word."
                -- Andrew Jackson
		




More information about the SDL mailing list