[SDL] Fullscreen problems

vining at pacificcoast.net vining at pacificcoast.net
Fri Apr 28 10:45:48 PDT 2000


>On Fri, Apr 28, 2000 at 11:50:19AM -0400, Sean Thomas Middleditch wrote:
>
>> I've just upgraded to XF86 4.0 and the new nVidia drivers.  All SDL apps
>> that use fullscreen act REALLY weird... the whole screen turns black, and a
>
>SoF works fine here with the NVIDIA drivers and SDL from CVS.

True -- but this does vindicate a few of the more unusual problems that I've been having with XF86 4.0 and the DRI. Most 
notably:

-- seismic (my app) crashes, and pulls down the entire machine.
-- Jabberwock (also my app) and testgl are not accelerated
-- My port of Nehe's lesson #19 is fine.

I'm catching bugs in my own sources, but I'm still finding interesting problems with other SDL GL apps. (The card checks out; I 
shoved it into a Win98 machine with the drivers that came with it, works nicely) I am inclined to pin it on SDL.... GLUT apps all 
seem to check out.... it may be my system configuration, however. I kludged it by not using a source tree. just using the standard 
binaries, a 2.3.51 kernel, and an updated drm driver from the 3Dfx web site -- however, that should all work.

You say SoF works? Hmm.... any chance you could burn me an alpha version and send it my way? (My contract will hopefully be 
arriving in the mail sometime soon, so it's not like it's something I wouldn't see anyways or would be inclined to share)
 
>m.

Nicho



More information about the SDL mailing list