[SDL] Verified XFree86 bugs

Sam Lantinga slouken at devolution.com
Thu Apr 6 18:07:16 PDT 2000


> >This works fine in XFree86 4.0, but XFree86 4.0 isn't binary compatible
> >with previous X servers.

> Not binary compatible in what regard? Surely you don't have to recompile
> clients linked to Xlib? DGA has changed, but is vidmode also different on
> the protocol level?

Yes.  Clients built with the pre-4.0 version of the VidMode library will
not work with 4.0 X servers and vice-versa.

Xlib is fine (I hope! :)

See ya,
	-Sam Lantinga, Lead Programmer, Loki Entertainment Software



More information about the SDL mailing list