[SDL] Re: SDL hangs on SDL_Init

David R. Hayes theraven at eris.cc
Thu Apr 6 08:03:45 PDT 2000


Sam Lantinga wrote:

> > I seem to be having the same problem in windows98. Sam, care to comment,
> > perhaps some more ignorance on my part?
>
> I can't think of anything offhand.  All the test programs hang as well?
>
> Do you have access to a debugger to find out where it's hanging?
>
> > "David R. Hayes" wrote:
> > >
> > > Hi there,
> > >     Hey, my first time writing to a newsgroup... anyway, I'm having a
> > > problem: I'm writing a game with SDL, and it appears to freeze on the
> > > call to SDL_Init. I'm running Linux, RedHat 6.0... none of the SDL
> > > test programs get past SDL_Init either. Everything seems to be linking
> > > correctly, and when I trace through, it's freezing on a call to some X
> > > function ( XF86VidModeGetModeLine). I'm at a loss.
>
> That's a problem...
> Try reconfiguring the source with --disable-video-x11-vm
> It's amazing how many servers freeze with that protocol.
>
>         -Sam Lantinga, Lead Programmer, Loki Entertainment Software

Hey Sam,
    I tried it and it was no go... / = Still freezing in the same place.
Argh. I'm the one that's running X ver. 3.3.5... would upgrading X be an
answer? I tried running at different resolutions (I'm at 1280 x 1024 at 32
bpp) and it still hanged on the SDL_Init call.

    Thanks,
        David




More information about the SDL mailing list