[SDL] Re: XFree86 4.0 VidMode not binary compatible

Sam Lantinga hercules at lokigames.com
Fri Apr 7 09:48:02 PDT 2000


Marc Aurele La France wrote:
> So what do we do now?  I think we need someone to assume "ownership" of
> this code and redesign the extension from scratch, which makes 3.3.* <->
> 4.0 compatibility not impossible, but unlikely.

Well, for our purposes, all we need it for is to switch the server into
fullscreen modes, and it works quite well for that purpose.  I haven't
checked to see if DGA 2.0 will do this without root permissions, but
since the vidmode extension still mostly works, we've been pretty happy
with it.

As far as vidmode incompatibility, I think I jumped the gun on this
one.  What had happened was I had compiled the code with XFree86 3
headers and then installed XFree86 4 and relinked.  Of course, this
doesn't work.  When I compile and link with the same set of headers and
libraries, everything appears to work properly.  My apologies.
-- 
	-Sam Lantinga, Lead Programmer, Loki Entertainment Software



More information about the SDL mailing list