[SDL] glibc version for SDL1.1.2 and 1.0.8?

ANOQ of the Sun anoq at HardcoreProcessing.com
Wed Apr 5 11:19:30 PDT 2000


Hello!


I'm wondering which version of glibc is really
required for native Linux compilation of SDL
applications. When installing the SDL rpms
(i tried both 1.1.2 and 1.0.8  +devels of course)
the dependencies claims that both glibc2.0 and
2.1 are required. I'm using libc6.0.7 on Debian
(which is supposed to be the stable version)
and when configuring the demos (warp, water,
plasma) i get an error during ./configure
that it can't run the SDL >= 1.0.1 test.
When looking at config.log, a lot of
symbols are not found in both glibc2.0
and glibc2.1. When upgrading to
libc6_2.1.3-8 the complaints about
undefined symbols disappears in config.lon,
but the SDL >= 1.0.1 test during configure
still does not run, and ldconfig starts to complain
that it can't find libraries such as libm, libpthread
etc. - which sounds like a disaster...

So I think I'll downgrade back to libc6.0.7

Any hints?

BTW - I seem to be able to crosscompile
the demos to Win32 just fine! :)
(except for the {prefix} issue in the generated
Makefile as mentioned earlier)


Cheers
--
http://www.HardcoreProcessing.com





More information about the SDL mailing list